Project

General

Profile

Problème appel entrant

Added by charly charles 3 months ago

Bonjour à tous,
Mon wazo est hébérgé chez OVH (serveur dédié).
Le trunk et le tél sont enregistrés.
Je ne comprend vraiment pas d'où viens mon problème d'appel entrant qui n’aboutit pas
Aucun souci sur les appels sortant par contre.
Ma SDA pointe vers mon utilisateur, malgré cela l'appel n'arrive pas sur mon tél.
Je pensais à un fail2ban qui aurait pu bannir mon IP...mais un "fail2ban-client status xivo-asterisk" m'indique que je ne suis pas banni.
Autre point important est que l'appel arrive sur mon poste si j'active l'option "Accepter un appel non authentifié" c'est à dire allowguest=yes. Je ne devrai jamais avoir à activer cette option !!
Je précise aussi que si je test sur un client Xlite, mes appels entrant/sortants sont fonctionnelles sur ce trunk

En vous remerciant pas avance pour vos retour.
Cordialement.


Replies (7)

RE: Problème appel entrant - Added by charly charles 3 months ago

Bonjour,
Je me suis rapproché de mon opérateur pour leur expliquer le problème.
Il me demande donc :
1- de modifier le champs contact => où s'effectue cette modification ?
2-de remplacer exten => s,1,NoOp()
exten => n,Set(DID=${CUT,@,1),:,2)})

à remplacer par :
exten => trunk,1,NoOp()
exten => n,Set(DID=${CUT(CUT(SIP_HEADER(To),@,1),:,2)}) => je ne sais pas non plus réaliser cette modification

Voici le retour de l'operateur
*"vu en ligne, nous attendrons votre retour concernant le changement du champ contact sur le trunk.
Actuellement celui-ci est en s@ à remplacer par trunk@

Pouvez-vous également nous fournir le fichier de conf du Xivo afin que l'on puisse le vérifier, car le allowguest devrait bien être sur "no"

Il est possible également que la routine du dialplan ne soit pas correct et se base sur un autre champ et de ce fait retourne cette erreur, ce qui expliquerait pourquoi le allowguest doit être actif pour que les appels passent .

Dans les faits vous devez avoir :

routine qui va récupérer la valeur du champs To:
exten => s,1,NoOp()
exten => n,Set(DID=${CUT,@,1),:,2)})

à remplacer par :
exten => trunk,1,NoOp()
exten => n,Set(DID=${CUT,@,1),:,2)})

Elle peut avoir une autre forme,mais l'idée est de traiter l'extension trunk au lieu de "s"
"*

RE: Problème appel entrant - Added by clement carlucci 2 months ago

Bonjour,

Pour moi le champ contact est dans le trunk/enregistrement/contact.
Pour la routine je n'arrive pas à le faire fonctionner.
Si quelqu'un a une idée.

RE: Problème appel entrant - Added by clement carlucci 2 months ago

Bonjour,

Après plusieurs tests j'ai réussi à faire fonctionner le mien.
1 Créer un contexte de type « Autre »
2 Mettre le contexte qui vient d’être créé dans Gestion des interconnexions/Protocole SIP/Général
3 rajouter le login dans le champ contact dans Gestion des interconnexions/Protocole SIP/Enregistrement
4 Dans IPBX / Configuration IPBX/ Fichier de configuration créer un fichier (peu importe le nom)
5 Mettre
[nom du contexte étape 1]
exten => login (même que le champ contact),1,Noop(Recuperation du SDA a partir du champ TO de l'entete SIP)
same => n,Set(pseudodid=${SIP_HEADER(To)})
same => n,Set(pseudodid=${CUT})
same => n,Set(pseudodid=${CUT})
same => n,Goto(from-extern,${pseudodid},1)
*From-extern (de la dernière ligne) est le contexte où va être rediriger les numéros

Pour moi tous les appels entrants sont fonctionnels mais je suis pas chez OVH mais Serveurcom.

RE: Problème appel entrant - Added by charly charles 2 months ago

Bonjour Clément,
Merci pour ton retour. Je vais tenter ta solution.
Cdt.

RE: Problème appel entrant - Added by charly charles 2 months ago

Clément,
je bloque sur certains points :

2 Mettre le contexte qui vient d’être créé dans Gestion des interconnexions/Protocole SIP/Général

Je ne sais pas de quel option "Général" tu me parle dans le menu Gestion des interconnexion. Peut-être parle tu du menu Paramètres Globaux\Protocole SIP\Général, puis mettre le contexte créé dans le champs "Contexte d'enregistrement"

*From-extern (de la dernière ligne) est le contexte où va être rediriger les numéros

Que faire pour le From-extern ?

En te remerciant par avance

RE: Problème appel entrant - Added by clement carlucci 2 months ago

2 Mettre le contexte qui vient d’être créé dans Gestion des interconnexions/Protocole SIP/Général : dans la configuration du trunk :
Dans la configuration du trunk

*From-extern (de la dernière ligne) est le contexte où va être rediriger les numéros :
Il faut meme le nom du contexte des appels entrants.

Capture.PNG View (25.6 KB)

RE: Problème appel entrant - Added by charly charles about 2 months ago

bonjour,
avec plusieurs jours de retard, je te remercie.
:)

    (1-7/7)