Project

General

Profile

CPU 100%

Added by Phil A about 2 months ago

Bonjour,

Voila mon serveur Wazo en version 18.03 ce matin est monté en charge à 100% de CPU en faisant un HTOP j'ai trois process "/usr/sbin/asterisk -g -U asterisk" à 144%, 71,1% et 70,9%, du coup plus de communications et plantage systeme me forcant a un reboot.

Comment identifier la source du probleme ? Une boucle ?

Merci

Philippe

2019-01-29 10_24_15 BUG WAZO.png View - Screen WAZO HTOP (97.9 KB)


Replies (5)

RE: CPU 100% - Added by Pascal Cadotte-Michaud about 2 months ago

Bonjour,

tu peux trouver des informations ici http://documentation.wazo.community/en/stable/contributors/debug_asterisk.html?highlight=debug%20asterisk#debugging-asterisk-freeze mais une partie de ces instructions doivent être exécuté pendant le problème.

si tu as un core dump dans /var/spool/asterisk tu pourras trouver les informations sur la même page de doc pour potentiellement en sortir des informations utiles.

RE: CPU 100% - Added by Phil A 28 days ago

Bonjour,

A l'instant plantage avec surcharge CPU :-( je suis en version 18.03 je dois donc bien installer les packages:

xivo-dist wazo-17.15
apt-get update
apt-get install gdb libc6-dbg
apt-get install -t wazo-17.15 asterisk-dbg xivo-libsccp-dbg
xivo-dist phoenix

Existe-t-il une procedure pour remonter l'utilisation d'un process en surcharge ?

Merci à vous.

RE: CPU 100% - Added by Sylvain Boily 28 days ago

Si tu es en 18.03, alors n'installe pas la 17.15. Combien as-tu d'appels en cours quand ton Asterisk est chargé ainsi ?

RE: CPU 100% - Added by Phil A 28 days ago

OK merci j'avais un doute avec un
asterisk -rx 'core show channels'
J'avais au moment du plantage 15 active channels et 9 active calls, j'ai maintenant sur mon IPBX 91 utilisateurs avec 2 coeurs et 6 Go RAM, le truc c'est qu'en plus 95 % du temps le serveur ne bronche pas avec un usage sur les deux CPU de 3 à 16 %

Merci,

RE: CPU 100% - Added by Sylvain Boily 28 days ago

Oui tu dois avoir un bug dans Asterisk sur un cas particulier. Si tu cherches dans le forum, tu devrais retrouver de l'info pour mettre à jour ton Asterisk en gardant ta version, cela pourra peut être aider.

    (1-5/5)