Project

General

Profile

unicom, pas d'audio

Added by Jean Cerien about 1 month ago

bonjour
j'ai un peu cherché ce sujet qui semble affecter d'autres, mais pas de solution pour moi, donc plutot que de détourner un thread, j'en créé un.

je cherche à utiliser phone.wazo.community. (unicom donc). comme indiqué, pas d'audio dans les 2 sens. si je configure un compte sip classique, et un trunk sip classique, ca marche.
je teste unicom sur un numéro local, qui décroche, joue un fichier son et fait un echo() - simple - et donc pas d'audio

le serveur est hosté sur un dédié avec IP publique, le client est classiquement derrière une box nattée (il a une ip locale et une ip de vpn). que j'active ou non iptables, pas de différence
l'IP publique du serveur est dans externip, nat=force,comedia ou no ne change rien

je joins les logs en annexe

seul truc louche, dans les logs asterisk:

[Nov  6 15:20:20] VERBOSE[6694][C-00000004] res_rtp_asterisk.c: 0x7fc77800e010 -- Strict RTP qualifying stream type: audio
[Nov  6 15:20:20] VERBOSE[6694][C-00000004] res_rtp_asterisk.c: 0x7fc77800e010 -- Strict RTP switching source address to ip.du.client.unicom:7078
[Nov  6 15:20:20] VERBOSE[6694][C-00000004] pbx.c: Executing [999@aae:5] Wait("SIP/jlg31bts-00000003", "1") in new stack
[Nov  6 15:20:20] VERBOSE[6694][C-00000004] res_rtp_asterisk.c: 0x7fc77800e010 -- Strict RTP learning complete - Locking on source address ip.du.client.unicom:7078
[Nov  6 15:20:21] VERBOSE[6694][C-00000004] pbx.c: Executing [999@aae:6] Playback("SIP/jlg31bts-00000003", "hello-world") in new stack
[Nov  6 15:20:21] VERBOSE[6694][C-00000004] file.c: <SIP/jlg31bts-00000003> Playing 'hello-world.slin' (language 'fr_FR')
[Nov  6 15:20:22] VERBOSE[6694][C-00000004] pbx.c: Executing [999@aae:7] Echo("SIP/jlg31bts-00000003", "") in new stack
[Nov  6 15:20:26] VERBOSE[5557][C-00000004] res_rtp_asterisk.c: 0x7fc77800e010 -- Strict RTP learning after remote address set to: 192.168.2.200:7078
[Nov  6 15:20:26] VERBOSE[6701] manager.c: HTTP Manager 'xivo_amid' logged on from 127.0.0.1
[Nov  6 15:20:26] VERBOSE[6701] manager.c: HTTP Manager 'xivo_amid' logged off from 127.0.0.1
[Nov  6 15:20:31] VERBOSE[5557][C-00000004] res_rtp_asterisk.c: 0x7fc77800e010 -- Strict RTP learning after remote address set to: 192.168.2.200:7078


on voit l'ip locale de mon client (192.168.2.200) ressortir
également dans les invite (cf log), une adresse
Via: SIP/2.0/WSS 192.0.2.69;branch=z9hG4bK7615831
bon, après c'est pas en relation avec le media

j'ai passé pas mal de temps à comprendre...sans trouver

L'aide sera la bienvenue....

J.

sipdebug.txt View (6.69 KB)


Replies (6)

RE: unicom, pas d'audio - Added by Sylvain Boily about 1 month ago

Tu as clairement un problème de configuration. As-tu modifié rtp.conf pour ajouter le support ice ?

RE: unicom, pas d'audio - Added by Jean Cerien about 1 month ago

Merci pour l'aide, toujours présent !

J'ai ajouté le STUN
stunaddr=stun:stun.voipstunt.com

mais je comprends pas pq ca coince, pq en théorie, j'ai du webrtc entre mon browser et le serveur http, pas de sip/nat donc encore à ce moment, puis ca cause en sip entre le 127.0.0.1 / serveur http et le asterisk - mais j'ai du rater qq chose

RE: unicom, pas d'audio - Added by Sylvain Boily about 1 month ago

Mais as-tu ajouté icesupport = yes dans rtp.conf ?

RE: unicom, pas d'audio - Added by Jean Cerien about 1 month ago

je viens de l'ajouter, pas de différence
j'ai un message
[Nov 8 08:34:44] > 0x7f0b6806f780 -- Strict RTP learning after ICE completion
sur la console, puis le rtp debug montre qu'il envoie les paquets sur l'IP publique de mon client - je m'attendais à ce que ca arrive sur le serveur http qui le pousse en webscoket vers mon ip publique client.

Il y a t il un endroit ou y'a une explication de toute la config à faire ? j'ai pas trouvé !

RE: unicom, pas d'audio - Added by Jean Cerien about 1 month ago

Bonjour
Je me permets de relancer - ou puis je trouver un guide pour la conf unicom ?
J.

RE: unicom, pas d'audio - Added by Sylvain Boily about 1 month ago

Allô,

Il n'existe pas de guide, il faut simplement un utilisateur avec une ligne Webtc de configuré. Après tout dépend de ton infra, donc y a pas de guide précis. Faut regarder par où passe ton rtp, regarder les paquets SIP. Unicom reste avant tout un projet pilote offert à la communauté, rien de plus.
Si tu as des idées de doc à faire pour le configurer je suis preneur.

Sylvain

    (1-6/6)