Project

General

Profile

Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ?

Added by Yann Nikolic about 1 year ago

Bonjour,

Ca faisait un moment que je n'avait pas eu de problème de crash avec Asterisk.

J'étais sur un debian en 32Bits.
Pensant pouvoir diminuer ou regler le problème de crash.
J'ai basculé ma configuration complète sur un nouveau serveur en 64 bit.

Procédure de Backup/Restore.

Mon Wazo est en version 17.17

Nous avons remarqué que ça arrivait lorsque certains appels arrivait sur des téléphones Cisco qui renvoyait l'appel à d'autre membres.
Malgré tout je ne suis même pas sure que le crash ce produit uniquement dans ce cas précis.

Le pire pour moi c'est de ne pas voir réellement la raison du crash. Dure de savoir quoi faire pour corriger.

Je souhaite faire le debuguage via la procédure : http://documentation.wazo.community/en/stable/contributors/debug_asterisk.html?highlight=debug%20asterisk

Comme ils sont en prod. Est-ce que la procédure coupe les communications ?

Ensuite, est ce que je peux vous envoyer quelques info pour tenter de m'aider sur ces crash.


Replies (6)

RE: Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ? - Added by Yann Nikolic about 1 year ago

J'ai trouvé ça dans syslog :
à l'heure du crash

Aug 2 09:29:39 telephonie kernel: [215762.684172] asterisk11540: segfault at 10 ip 00007f3f0a59a3cc sp 00007f3edbc9acd0 error 4 in app_queue.so[7f3f0a579000+42000]
Aug 2 09:29:39 telephonie systemd1: asterisk.service: main process exited, code=killed, status=11/SEGV
Aug 2 09:29:39 telephonie systemd1: Unit asterisk.service entered failed state.
Aug 2 09:29:39 telephonie systemd1: xivo-ctid.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Aug 2 09:29:39 telephonie systemd1: Unit xivo-ctid.service entered failed state.

RE: Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ? - Added by pj o 12 months ago

Salut
Si ton problème est toujours d'actualité tu peux jeter un oeil ici :
https://projects.wazo.community/issues/7108

RE: Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ? - Added by Yann Nikolic 12 months ago

Merci pour la réponse.

Oui, crash 1 fois par semaine en moyenne.

J'ai regardé le sujet. Mais je ne trouve pas de Dialplan custom sur ma conf.

Ou sont les diaplan custom en général?

RE: Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ? - Added by pj o 12 months ago

Tu peux les trouver dans la partie "Fichier de configuration". (là ou tu crée ton svi par exemple)

RE: Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ? - Added by Yann Nikolic 12 months ago

Merci je vais vois ça. (Je suis encore en congé je regarderais des que je peu.)
Je ne sais pas si c'est lié mais j'ai une petite question.
Pour les appels entrants venant de l’extérieur, c'est quoi le mieux ?

Les files d'attentes ou les groupes?

RE: Crash Asterisk cause inconnu. suspicion de problème avec les renvois d'appels ? - Added by Yann Nikolic 6 months ago

Bonjour Tout le monde !
Vieux Sujet qui remonte.

J'ai toujours pas résolu mon problème de crash asterisk avec mon client.
La périodicité du crash est d 1 fois par mois voir parfois 2

Ah oui . si je met à jour vers la dernière version de Wazo c'est 2 plantages par jour.

Je pense faire un nouveau Standard de 0 sans importer la configuration du Wazo actuelle.

Je pense faire une interconnexion entre les 2 Wazo pour pouvoir basculer petit à petit les utilisateurs.

Qu'en pensez vous?

    (1-6/6)