Project

General

Profile

Titre reformulé: mauvais Sdp. Plus d audio avec externip. Comment dois je configurer le protocole sip. [Résolu]

Added by Yann Nikolic about 1 year ago

Bonjour tout le monde.

Je reformule mon post.

En appel entrant, mon operateur recois des invite de ma par avec l ip privé.

Mais quand je renseigne externip. Je n ai plus d audio sur mes tel connecté en vpn. Et meme, l enregistrement trunk ne se fait plus. Je doit avoir une mauvaise configuration.

Si dessous mes posts précédants.

J ai l impression de redevenir un gros debutant.

Bonjour tout le monde.

J'ai mon opérateur qui m'a demandé de changer mon Délai d'expiration à 300 (expiry)
Ils ont modifié leurs serveur depuis peu et depuis j'ai des soucis sur quelques un de mes standard Wazo.

Depuis j'ai des communication entrante qui coupe par moment.
On va être injoignable pendant quelque seconde. Et puis nous sommes à nouveau joignable;

J'ai contacté mon opérateur,
il m'a dit qu'il perdait notre enregistrement régulièrement et qu'au bout de quelques seconde l'enregistrement se reconnectait.

Ils m'ont demandé à combien était le refresh lorsque je fait la commande sip show registry. il est a 285.

Host dnsmgr Username Refresh State Reg.Time
operateur:5060 N username 285 Registered Date et heure

Il m'ont demandé si je pouvait modifier le re-register à une valeur de 150.

Est ce que c'est possible ?


Replies (9)

RE: Coupure Appel entrant - Délai d'expiration enregistrement 300 - refresh ou re-register à 285 comment le modifier ? - Added by Yann Nikolic about 1 year ago

Bon a priori j'ai plein de problème avec les appels entrant avec OpenIP
et la dernière version de Wazo/Asterisk.

les communication entrante finissent par couper ou ne pas aboutir aléatoirement.

Voici l'extrait d'un dialogue que j'ai avec mon support opérateur :


Rappel d'un fonctionnement classique:
Pour la gestion du flux audio, il y a 2 méthodes.
Soit c'est vous qui initiez le RTP, donc depuis une certaine adresse IP et depuis un certain port.
Soit vous n'initiez pas le RTP et c'est notre serveur qui le fait.
Dans ce cas, nous nous basons sur les champs contenus dans le SDP (Session Description Protocol) envoyé dans le 200 OK suite à l'Invite entrant.

Sur l'appel en défaut du 06........ vers le 01...... le 2018/07/.. 14:..:.., nous constatons que dans le SDP envoyé dans le 200 OK il y a une adresse IP privée.
Au début de la communication, c'est vous qui avez initié le RTP, d'où le fait que les 2 interlocuteurs s'entendent correctement.

Pendant la communication, notre serveur a renvoyé un autre Invite à votre IPBX afin de s'assurer qu'il soit toujours présent.
A cet Invite, vous nous avez répondu 200 OK (donc avec l'adresse IP privée dans le SDP).

Le flux RTP a donc été renvoyé vers cette adresse IP privée, d'où le fait que vous ayez des pertes d'audios durant la communication.

Qu'en pensez vous ?
Est ce que ça parle à l'un d'entre vous ?

RE: Coupure Appel entrant - Délai d'expiration enregistrement 300 - refresh ou re-register à 285 comment le modifier ? - Added by Dominique Da Fonseca about 1 year ago

Bonjour,
ton serveur est donc en NAT derrière ton routeur, il faut que tu configure ton trunk comme étant en NAT puis renseigner ton IP (externe) publique dans les paramètres SIP globaux dans l'onglet réseaux

RE: Coupure Appel entrant - Délai d'expiration enregistrement 300 - refresh ou re-register à 285 comment le modifier ? - Added by Yann Nikolic about 1 year ago

Merci pour la réponse.

C'est fait.

Mais depuis mes téléphones en local n'on plus de son.

Qu'est ce que j'ai raté dans ma configuration ?

RE: Coupure Appel entrant - Délai d'expiration enregistrement 300 - refresh ou re-register à 285 comment le modifier ? - Added by Yann Nikolic about 1 year ago

Je perd également le registry, il ne veux plus s'enregistrer après cette modification.

RE: Coupure Appel entrant - Délai d'expiration enregistrement 300 - refresh ou re-register à 285 comment le modifier ? - Added by Yann Nikolic about 1 year ago

Je ne pense pas avoir eu ces problème avec les versions précédente de Wazo.
Je n'avais pas besoin de renseigner l'IP Public.
Mais il est possible que l'opérateur ai fait des modifications de leur coté.
Quoi qu'il en soit j'ai un serveur Wazo en 17 qui lui n'as pas de problème et je n'ai rien modifié.

Voici ma Configuration. (avec ip fictives.)

Coté serveur
Serveur WAZO IP: 10.0.0.1
Routeur IP : 10.0.0.254
IP Public : xxx.xxx.xxx.xxx
Liaison trunk sip avec l'opérateur

Pour les téléphones.
Liaison VPN réseau 10.0.0.0/24 <-> 10.1.0.0/24
Routeur Client : 10.1.0.254
Téléphones client : 10.1.0.x

Je n'arrive plus a trouver la bonne configuration en activant "externip"

Je n'ai plus d'audio sur les téléphones et je n'ai plus d'enregistrement avec l'opérateur.

Extrait de la doc de l'opérateur. Configuration du trunk.

[general]
context=default
bindport=5060
bindaddr=0.0.0.0
externip=IP PUBLIQUE
localnet=ADRESSE RESEAU LOCAL/MASQUE DE SOUS RESEAU
nat=yes
CONSOLE=/dev/dsp
qualify=yes
dtmfmode=rfc2833
canreinvite=no
register => LOGIN:PASSWORD@openip/LOGIN
[openip]
type=friend
username=LOGIN
secret=PASSWORD
host=SERVER
insecure=invite,port
disallow=all
allow=ulaw

RE: Titre reformulé: mauvais Sdp. Plus d audio avec externip. Comment dois je configurer le protocole sip. - Added by Yann Nikolic about 1 year ago

Je vient de réalisé que je n'avais pas coché 1 case dans ma configuration SIP.

"Remplacer l'IP ou l'hôte externe s'il correspond au réseau local" !

Je ne suis pas au bureau pour tester si ça fonctionne.

Je vous ai joint une capture d'écran de ma conf.
Est ce que c'est correct?

RE: Titre reformulé: mauvais Sdp. Plus d audio avec externip. Comment dois je configurer le protocole sip. - Added by Yann Nikolic about 1 year ago

Bon c'est tres bon signe, j'ai bien réglé sur le NAT le trunk SIP et il s'enregistre.
J'arrive a passer des appels et j'entend bien mon SVI.

Il reste plus qu'a tester mes téléphones en interne.

RE: Titre reformulé: mauvais Sdp. Plus d audio avec externip. Comment dois je configurer le protocole sip. - Added by Yann Nikolic about 1 year ago

C'est tout Bon.

J'était mal parti mais c'est réglé maintenant.

Merci Dominique pour la piste que tu m'as donné.

Réglage ExternIP + Remplacer l'IP ou l'hôte externe s'il correspond au réseau local
+ mes réseaux locaux.

Réglage défaut avec NAT
+
Protocole SIP avec NAT

Tout est ok.

Merci beaucoup.

    (1-9/9)