Project

General

Profile

Wazo Centrex

Added by Franck OUILLE about 2 years ago

Bonjour,

Je suis entrain de tester Wazo en mode "centrex", en hébergé sur une VM,
Je suis confronté à quelques difficultés :
- niveau provisionning : une fois fait en autoprov, impossible de renvoyer la requete de provision il faut relancer ou resetter le poste

*- appels : les appels 'fonctionnent' en revanche je n'ai pas de flux audio *
Capture :
U 10.3.14.133:5060 -> 86.225.148.80:48468
SIP/2.0 100 Trying.
Via: SIP/2.0/UDP 192.168.0.10:15060;branch=z9hG4bK723776596;received=86.225.148.80;rport=48468.
From: "Henry DUPOND" <sip::5060>;tag=3247174192.
To: <sip:*:5060>.
Call-ID: .
CSeq: 1 INVITE.
Server: MOTelecom.
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE.
Supported: replaces, timer.
Contact: <sip:*:5060>.
Content-Length: 0.
.

U 10.3.14.133:5060 -> 86.225.148.80:48468
SIP/2.0 200 OK.
Via: SIP/2.0/UDP 192.168.0.10:15060;branch=z9hG4bK723776596;received=86.225.148.80;rport=48468.
From: "Henry DUPOND" <sip::5060>;tag=3247174192.
To: <sip:*:5060>;tag=as14f5ea4d.
Call-ID: .
CSeq: 1 INVITE.
Server: MOTelecom.
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE.
Supported: replaces, timer.
Contact: <sip:*:5060>.
Content-Type: application/sdp.
Content-Length: 318.
.
v=0.
o=root 536244795 536244795 IN IP4 10.3.14.133.
s=Asterisk PBX 14.6.1.
c=IN IP4 10.3.14.133.
t=0 0.
m=audio 12956 RTP/AVP 0 8 18 101.
a=rtpmap:0 PCMU/8000.
a=rtpmap:8 PCMA/8000.
a=rtpmap:18 G729/8000.
a=fmtp:18 annexb=no.
a=rtpmap:101 telephone-event/8000.
a=fmtp:101 0-16.
a=ptime:20.
a=maxptime:150.
a=sendrecv.

U 10.3.14.133:5060 -> 86.225.148.80:48468
SIP/2.0 200 OK.
Via: SIP/2.0/UDP 192.168.0.10:15060;branch=z9hG4bK723776596;received=86.225.148.80;rport=48468.
From: "Henry DUPOND" <sip::5060>;tag=3247174192.
To: <sip:*:5060>;tag=as14f5ea4d.
Call-ID: .
CSeq: 1 INVITE.
Server: MOTelecom.
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE.
Supported: replaces, timer.
Contact: <sip:*:5060>.
Content-Type: application/sdp.
Content-Length: 318.
.
v=0.
o=root 536244795 536244795 IN IP4 10.3.14.133.
s=Asterisk PBX 14.6.1.
c=IN IP4 10.3.14.133.
t=0 0.
m=audio 12956 RTP/AVP 0 8 18 101.
a=rtpmap:0 PCMU/8000.
a=rtpmap:8 PCMA/8000.
a=rtpmap:18 G729/8000.
a=fmtp:18 annexb=no.
a=rtpmap:101 telephone-event/8000.
a=fmtp:101 0-16.
a=ptime:20.
a=maxptime:150.
a=sendrecv.

Est ce que ce mode d'utilisation est prévus dans Wazo ?
Réglages appliqués :
Protocole sip : NAT RPORT + COMEDIA
Configuration / parametres generaux/ NAT = 1

Merci
Franck


Replies (8)

RE: Wazo Centrex - Added by Dominique Da Fonseca about 2 years ago

bonjour,
nous avons quelques IPBX en mode hébergés donc cela fonctionne sans problèmes.
Ton IPBX est-il naté derrière un routeur ?
Tes postes sont-ils natés derrière un routeur ? un proxy SIP ?

ton flux RTP semble perdu quelque part
pour la fonctionnalité de reset du poste suite au provisioning si tous tes éléments sont natés derrières des routeurs c'est logique

Le plus simple pour ce genre d'infra est de monter un VPN entre ton IPBX hébergé et tes postes, ça évitera de te faire pirater ton IPBX

RE: Wazo Centrex - Added by Franck OUILLE about 2 years ago

Ton IPBX est-il naté derrière un routeur ? je ne sais pas trop c'est une VM chez Online.net
Tes postes sont-ils natés derrière un routeur ? oui

VPN c'est possible de le monter directement dans les postes Yealink ?

RE: Wazo Centrex - Added by Dominique Da Fonseca about 2 years ago

Franck OUILLE wrote:

Ton IPBX est-il naté derrière un routeur ? je ne sais pas trop c'est une VM chez Online.net

donc elle est surement directement en publique, donc je te conseille de bien la protéger par un firewall IPTABLES

Tes postes sont-ils natés derrière un routeur ? oui

ce qui explique le soucis de flux RTP interrompu, il faut que tu analyse tes trames RTP avec tcpdump sniffer sur ton routeur si c'est possible

VPN c'est possible de le monter directement dans les postes Yealink ?

oui c'est tout a fait possible et relativement simple a mettre en place, si tous tes postes sont sur le même site il est encore plus simple de monter un VPN "site à site" depuis ton routeur/firewall, apres tout dépend du routeur utilisé.

RE: Wazo Centrex - Added by Franck OUILLE about 2 years ago

Après tests j'ai un autre serveur depuis plus longtemps quand je provisionne cela fonctionne parfaitement y compris la voix

Je renouvelle les tests sur le nouveau serveur provision OK mais toujours la de voix... et j'arrive pas a voir la différence entre les deux niveau réglage

RE: Wazo Centrex - Added by Franck OUILLE about 2 years ago

Je suis désolé de remonter ce post mais je galère :)

J'ai fait une capture tshark directement sur le serveur en PJ par contre je ne sais pas lire cette capture

En constat :
Poste provisionné sur un autre Wazo en VM : OK
Meme provision sur une nouvelle VM : pas de voix entrant / sortant

Merci par avance,

capture.cap (315 KB)

RE: Wazo Centrex - Added by Franck OUILLE about 2 years ago

Bon bha je viens de trouver :)

C'était un filtrage chez mon hebergeur où il fallait que j'ouvre RTP UDP Entrant 10000-20000 ....

Si quelqu'un peut m'expliquer tout de même comment voir cela dans la capture de trame

RE: Wazo Centrex - Added by Sylvain Boily about 2 years ago

Tu peux juste debugger ce souci avec rtp set debug dans la cli asterisk.

RE: Wazo Centrex - Added by Sébastien Duthil about 2 years ago

Tu sembles avoir un problème de NAT aussi: dans ta capture:
  • le paquet 605 est un paquet SIP reçu du téléphone, où celui-ci dit "je suis à l'adresse 192.168.0.10" (SDP: connection information)
  • le paquet 819 est un paquet RTP envoyé du Wazo vers 192.168.0.10, ce qui n'est pas routable
  • le paquet 871 est un paquet ICMP où le routeur dit "c'est pas routable ton histoire" (Communication administratively filtered)
    (1-8/8)