Project

General

Profile

[RESOLU] Greffon xivo-aastra-4.3.0 / 6867i-fw

Added by Phil A over 2 years ago

Bonjour à tous,

J'ai reçu un Aastra/Mitel 6867i et en voulant installer le greffon dans sa dernière version en 4.3.0 sur un Wazo 17.12 je rencontre l'erreur suivante: "6867i-fw a rencontré une erreur durant l'installation"

Voici le log d'erreur du fichier xivo-provd.log:


2017-09-05 10:14:17,284 [944] (INFO) (provd.app): Installing and loading plugin xivo-aastra-4.3.0
2017-09-05 10:14:17,284 [944] (INFO) (provd.plugins): Installing plugin xivo-aastra-4.3.0
2017-09-05 10:14:17,286 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:16 +0000] "POST /provd/pg_mgr/install/install HTTP/1.1" 201 - "-" "-"
2017-09-05 10:14:17,389 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:17 +0000] "GET /provd/pg_mgr/install/install/4 HTTP/1.1" 200 55 "-" "-"
2017-09-05 10:14:17,757 [944] (INFO) (provd.plugins): Plugin xivo-aastra-4.3.0 installed
2017-09-05 10:14:17,758 [944] (INFO) (provd.plugins): Loading plugin xivo-aastra-4.3.0
2017-09-05 10:14:17,764 [944] (INFO) (provd.plugins): Notifying plugin manager observer <provd.plugins.BasePluginManagerObserver object at 0x7fee6e922c10>
2017-09-05 10:14:17,764 [944] (INFO) (provd.plugins): Notifying plugin manager observer <provd.plugins.BasePluginManagerObserver object at 0x7fee6e929c90>
2017-09-05 10:14:17,764 [944] (INFO) (provd.app): Configuring plugin xivo-aastra-4.3.0 with config {u'tftp_port': 69, u'_comment': u'see provd.conf for info about this file', u'http_port': 8667, u'ip': u'172.20.64.250'}
2017-09-05 10:14:17,764 [944] (INFO) (provd.app): Reconfiguring all devices using plugin xivo-aastra-4.3.0
2017-09-05 10:14:18,394 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:18 +0000] "GET /provd/pg_mgr/install/install/4 HTTP/1.1" 200 56 "-" "-"
2017-09-05 10:14:18,395 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:18 +0000] "DELETE /provd/pg_mgr/install/install/4 HTTP/1.1" 204 - "-" "-"
2017-09-05 10:14:18,499 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:18 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/info HTTP/1.1" 200 369 "-" "-"
2017-09-05 10:14:18,500 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:18 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/installed HTTP/1.1" 200 11 "-" "-"
2017-09-05 10:14:18,501 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:18 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/installable HTTP/1.1" 200 568 "-" "-"
2017-09-05 10:14:18,502 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:14:18 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/configure HTTP/1.1" 404 153 "-" "-"
2017-09-05 10:15:29,149 [944] (INFO) (provd.plugins): Installing plugin-package 6867i-fw
2017-09-05 10:15:29,150 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:15:28 +0000] "POST /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install HTTP/1.1" 201 - "-" "-"
2017-09-05 10:15:29,249 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:15:28 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install/1 HTTP/1.1" 200 91 "-" "-"
2017-09-05 10:15:30,250 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:15:29 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install/1 HTTP/1.1" 200 96 "-" "-"
.....
2017-09-05 10:18:24,250 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:23 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install/1 HTTP/1.1" 200 99 "-" "-"
2017-09-05 10:18:25,251 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:24 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install/1 HTTP/1.1" 200 99 "-" "-"
2017-09-05 10:18:25,815 [944] (ERROR) (xivo_fetchfw.install): Error during execution of installation manager
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/xivo_fetchfw/install.py", line 80, in execute
filter_obj.apply(input_dir, output_dir)
File "/usr/lib/python2.7/dist-packages/xivo_fetchfw/install.py", line 371, in apply
for pathname in self._glob_helper.iglob_in_dir(src_directory):
File "/usr/lib/python2.7/dist-packages/xivo_fetchfw/install.py", line 271, in iglob_in_dir
% (self._pathnames, src_directory))
InstallationError: the glob patterns ['58015041-REV02_4.3.0.1052_SP1_6867i.zip'] did not match anything in directory '/tmp/tmp5R5suP/node_a'
2017-09-05 10:18:25,816 [944] (INFO) (provd.plugins): Error while installating plugin-package 6867i-fw: the glob patterns ['58015041-REV02_4.3.0.1052_SP1_6867i.zip'] did not match anything in directory '/tmp/tmp5R5suP/node_a'
2017-09-05 10:18:26,249 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:25 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install/1 HTTP/1.1" 200 90 "-" "-"
2017-09-05 10:18:26,250 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:25 +0000] "DELETE /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/install/1 HTTP/1.1" 204 - "-" "-"
2017-09-05 10:18:26,311 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:26 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/info HTTP/1.1" 200 369 "-" "-"
2017-09-05 10:18:26,312 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:26 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/installed HTTP/1.1" 200 11 "-" "-"
2017-09-05 10:18:26,313 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:26 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/install/installable HTTP/1.1" 200 568 "-" "-"
2017-09-05 10:18:26,314 [944] (INFO) (twisted): 127.0.0.1 - - [05/Sep/2017:08:18:26 +0000] "GET /provd/pg_mgr/plugins/xivo-aastra-4.3.0/configure HTTP/1.1" 404 153 "-" "-"

Auriez-vous une piste ?

Merci


Replies (3)

RE: Greffon xivo-aastra-4.3.0 / 6867i-fw - Added by Sylvain Boily over 2 years ago

Apparement le firmware en 4.3.0 a été supprimé et remplacé en 5.0.0. Il faut que nous mettions à jour le plugin.

RE: Greffon xivo-aastra-4.3.0 / 6867i-fw - Added by Phil A over 2 years ago

Oui en effet je viens de vérifier sur le site de Mitel et la V5 est sortie en aout... Je vais patienter ou utiliser la version 4.1.0 du plugin.

Merci !

Philippe

RE: Greffon xivo-aastra-4.3.0 / 6867i-fw - Added by Phil A over 2 years ago

La version 5 ne semble plus disponible chez Mitel mais depuis la mise à jour du greffon la version 4.3 fonctionne parfaitement.

Merci pour votre travail

    (1-3/3)