Project

General

Profile

Parametrage Wazo > Siproxd pas d'usager correspondant au numero

Added by Jeremy M 7 months ago

Bonsoir, je suis venu chercher un peu d'aide sur votre forum concernant mon installation un peu particuliere... J'ai un abonnement fibre orange pro. Je souhaite me passé de la livebox et recuperer mon numero sip pour pouvoir gerer un pre dec / musique d'attente et horaire.

J'ai sur le meme serveur une VM Pfsense qui recupere donc internet. ( la tout est ok).
Sur une autre VM j'ai debian avec Siproxd + Xivo / Wazo. Le siproxd est fonctionnel puisque aujourd hui mon tel IP C530IP se connecte sur Siproxd pour pouvoir appeler.

Pour Xivo / Wazo , quand j'essai d'appelé de l'exterieur vers mon numero sip, j'ai un message " il n'y a pas d'usager correspondant au numero demandé".

Le CLI nous donne :

[Apr 18 21:25:37] == Using SIP RTP CoS mark 5
[Apr 18 21:25:37] -- Executing [s@default:1] NoOp("SIP/Entrant_livebox-0000000c", "") in new stack
[Apr 18 21:25:37] -- Executing [s@default:2] GotoIf("SIP/Entrant_livebox-0000000c", "1?:not-sip") in new stack
[Apr 18 21:25:37] -- Executing [s@default:3] GotoIf("SIP/Entrant_livebox-0000000c", "1?:error-loop") in new stack
[Apr 18 21:25:37] -- Executing [s@default:4] Set("SIP/Entrant_livebox-0000000c", "XIVO_DID_NEXT_EXTEN=+33547*******") in new stack
[Apr 18 21:25:37] -- Executing [s@default:5] Set("SIP/Entrant_livebox-0000000c", "XIVO_FROM_S=1") in new stack
[Apr 18 21:25:37] -- Executing [s@default:6] Goto("SIP/Entrant_livebox-0000000c", "from-extern,+33547*******,1") in new stack
[Apr 18 21:25:37] -- Goto (from-extern,+33547*****,1)
[Apr 18 21:25:37] -- Executing [+33547******@from-extern:1] Goto("SIP/Entrant_livebox-0000000c", "33547******,1") in new stack
[Apr 18 21:25:37] -- Goto (from-extern,33547*****,1)
[Apr 18 21:25:37] -- Channel 'SIP/Entrant_livebox-0000000c' sent to invalid extension: context,exten,priority=from-extern,33547*****,1
[Apr 18 21:25:37] -- Executing [i@from-extern:1] Playback("SIP/Entrant_livebox-0000000c", "no-user-find") in new stack
[Apr 18 21:25:37] == Using SIP RTP CoS mark 5
[Apr 18 21:25:37] -- Executing [s@default:1] NoOp("SIP/Entrant_livebox-0000000d", "") in new stack
[Apr 18 21:25:37] -- Executing [s@default:2] GotoIf("SIP/Entrant_livebox-0000000d", "1?:not-sip") in new stack
[Apr 18 21:25:37] -- Executing [s@default:3] GotoIf("SIP/Entrant_livebox-0000000d", "1?:error-loop") in new stack
[Apr 18 21:25:37] -- Executing [s@default:4] Set("SIP/Entrant_livebox-0000000d", "XIVO_DID_NEXT_EXTEN=+33547*****") in new stack
[Apr 18 21:25:37] -- Executing [s@default:5] Set("SIP/Entrant_livebox-0000000d", "XIVO_FROM_S=1") in new stack
[Apr 18 21:25:37] -- Executing [s@default:6] Goto("SIP/Entrant_livebox-0000000d", "from-extern,+33547******,1") in new stack
[Apr 18 21:25:37] -- Goto (from-extern,+33547*****,1)
[Apr 18 21:25:37] -- Executing [+33547******@from-extern:1] Goto("SIP/Entrant_livebox-0000000d", "33547*****,1") in new stack
[Apr 18 21:25:37] -- Goto (from-extern,33547******,1)
[Apr 18 21:25:37] -- Channel 'SIP/Entrant_livebox-0000000d' sent to invalid extension: context,exten,priority=from-extern,33547******,1
[Apr 18 21:25:37] -- Executing [i@from-extern:1] Playback("SIP/Entrant_livebox-0000000d", "no-user-find") in new stack
[Apr 18 21:25:37] == Using SIP RTP CoS mark 5
[Apr 18 21:25:37] -- Executing [s@default:1] NoOp("SIP/Entrant_livebox-0000000e", "") in new stack
[Apr 18 21:25:37] -- Executing [s@default:2] GotoIf("SIP/Entrant_livebox-0000000e", "1?:not-sip") in new stack
[Apr 18 21:25:37] -- Executing [s@default:3] GotoIf("SIP/Entrant_livebox-0000000e", "1?:error-loop") in new stack
[Apr 18 21:25:37] -- Executing [s@default:4] Set("SIP/Entrant_livebox-0000000e", "XIVO_DID_NEXT_EXTEN=+33547******") in new stack
[Apr 18 21:25:37] -- Executing [s@default:5] Set("SIP/Entrant_livebox-0000000e", "XIVO_FROM_S=1") in new stack
[Apr 18 21:25:37] -- Executing [s@default:6] Goto("SIP/Entrant_livebox-0000000e", "from-extern,+33547******,1") in new stack
[Apr 18 21:25:37] -- Goto (from-extern,+33547******,1)
[Apr 18 21:25:37] -- Executing [+33547******@from-extern:1] Goto("SIP/Entrant_livebox-0000000e", "33547******from-extern,33547*****,1
[Apr 18 21:25:37] -- Executing [i@from-extern:1] Playback("SIP/Entrant_livebox-0000000e", "no-user-find") in new stack
[Apr 18 21:25:37] -- <SIP/Entrant_livebox-0000000c> Playing 'no-user-find.slin' (language 'fr_FR')
[Apr 18 21:25:37] -- <SIP/Entrant_livebox-0000000d> Playing 'no-user-find.slin' (language 'fr_FR')
[Apr 18 21:25:37] > 0x7f30f4005970 -- Probation passed - setting RTP source address to 192.168.1.140:7076
[Apr 18 21:25:37] -- <SIP/Entrant_livebox-0000000e> Playing 'no-user-find.slin' (language 'fr_FR')
[Apr 18 21:25:41] -- Executing [i@from-extern:2] Hangup("SIP/Entrant_livebox-0000000c", "") in new stack
[Apr 18 21:25:41] Spawn extension (from-extern, i, 2) exited non-zero on 'SIP/Entrant_livebox-0000000c'
[Apr 18 21:25:41] -- Executing [i@from-extern:2] Hangup("SIP/Entrant_livebox-0000000d", "") in new stack
[Apr 18 21:25:41] Spawn extension (from-extern, i, 2) exited non-zero on 'SIP/Entrant_livebox-0000000d'
[Apr 18 21:25:41] -- Executing [i@from-extern:2] Hangup("SIP/Entrant_livebox-0000000e", "") in new stack
[Apr 18 21:25:41] == Spawn extension (from-extern, i, 2) exited non-zero on 'SIP/Entrant_livebox-0000000e'

puis

WARNING7719: chan_sip.c:4064 retrans_pkt: Retransmission timeout reached on transmission SD05kbe01-6c24aff90c4a5e3b13d53fc177b65762-1eurdu1 for seqno 21100153 (Critical Response) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 32000ms with no response

Pour les appels sortant c'est pareil.

Pour la partie reseau, siproxd ecoute sur le port 5070, redirection faite sur le routeur ainsi que le port 7070 à 7089.

Si quelqu'un a une idée sur ce type d'erreur, je suis preneur.


Replies (5)

RE: Parametrage Wazo > Siproxd pas d'usager correspondant au numero - Added by Dominique Da Fonseca 7 months ago

bonjour,
je suis utilisateur de siproxd mais dans un contexte totalement différent, le WAZO est dans le cloud le siproxd embarqué dans un PFsense et mes téléphones en interne derrière le coupe SIPROXD/PFsense

mais la donc a ce que je comprends ton WAZO se trouve derrière SIPROXD ?
en fait je n'ai pas compris ton archi ??

RE: Parametrage Wazo > Siproxd pas d'usager correspondant au numero - Added by Jeremy M 7 months ago

Oui effectivement mon utilisation de siproxd est differente.

J'utilise un lien orange fibre optique pro. Avec la fibre j'ai la possibilité de passer des appels illimité depuis le tel de la livebox mais dans mon cas j'ai supprimé la livebox qui est remplacé par Pfsense.
La telephonie d'orange passe par le protocole "SIP" mais orange a choisie de modifier le standard. Siproxd est une version modifiée qui permet donc de se connecter au reseau d'orange et de pouvoir utiliser les 2 comptes sip comme si j'avais une livebox.
L'avantage de cette solution est de pouvoir mettre Wazo sur le reseau et de pouvoir donc gerer les appels, une plage horaire, un pre dec.... comme avec un operateur SIp classique

Donc pour resumer, sur le meme reseau j'ai

Lien orange fibre > PFSENSE ( 192.168.1.1) > Siproxd ( Qui fonctionne 192.168.1.140) > Wazo ( sur le meme OS que Siproxd ou j'ai essayé en dissociant les 2) Wazo est censé recuperer les liens SIP sur le Siproxd.

Apparemment depuis l’extérieur je pense que Wazo arrive a recevoir des infos de siproxd puisque le CLI m'affiche certaines info lors d'un appel.
CE que je comprends pas c est pourquoi Wazo ne redirige pas les appels vers le tel IP ou vers un softphone comme demandé.

RE: Parametrage Wazo > Siproxd pas d'usager correspondant au numero - Added by Romain Martin 7 months ago

J'ai eu le même problème, ça fonctionnait en utilisant directement un softphone (sans pfsense) avec les identifiants SIP de Siproxd mais pas possible de le faire fonctionner avec xivo a l'époque.
Depuis j'ai abandonné et je suis passé sur un gateway FXO mais il y a perte de qualité.

RE: Parametrage Wazo > Siproxd pas d'usager correspondant au numero - Added by Dominique Da Fonseca 7 months ago

aaaah voila c'est plus clair ainsi :D

on va avoir besoin de debug SIP, pour jeter un oeuil à l'entête SIP

la SDA qui est +33547******* et tu ne peux pas mettre le + dans tes appels entrants il vas falloir ruser, un dialplan qui ferai sauter le + par exemple

et sur un appel sortant ça ne fonctionne pas non plus ? ça te donne quoi comme erreur ?

tu peux nous mettre la configuration de ton trunk entre XiVO et SIPROXD aussi

RE: Parametrage Wazo > Siproxd pas d'usager correspondant au numero - Added by Romain Martin 7 months ago

Dominique Da Fonseca J'ai retrouvé sur le forum du projet siproxd la config xivo d'une autre personne qui avait lui aussi apparemment le même problème que nous et il avait donné sa configuration.
https://lafibre.info/remplacer-livebox/remplacer-livebox-le-telephone/336/

    (1-5/5)