Project

General

Profile

Cannot install latest version

Added by Alan Murrell 9 days ago

Hello,

I have done a minimal Debian 9 install, made sure my locale was a UTF-8 one, but when I run the 'wazo_install.sh' script, I get the following errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xivo : Depends: xivo-base (= 14:18.09~20180723.121014.86a4a4d.deb9) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
dahdi-linux-modules-4.9.0-4-amd64 is already the newest version (2:2.11.1-1~xivo5.deb9+4.9.65-3+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xivo-base : Depends: wazo-auth but it is not going to be installed
             Depends: wazo-dird but it is not going to be installed
             Depends: wazo-service but it is not going to be installed
             Depends: wazo-webhookd but it is not going to be installed
             Depends: xivo-confd but it is not going to be installed
             Depends: xivo-ctid-ng but it is not going to be installed
             Depends: xivo-manage-db but it is not going to be installed
             Depends: xivo-websocketd but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xivo : Depends: xivo-base (= 14:18.09~20180723.121014.86a4a4d.deb9) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
./wazo_install.sh: line 65: xivo-service: command not found

It seems the source of it all is that Debian 9 installs postgresql-9,6,10 and xivo-dms wants postgresql-9.6.9 (xivo-dbms is a dependancy of wazo-auth, which is a dependancy of xivo-base). If I install from the ISO, it seems to just install a minimal Debian but absolutely no Wazo packages whatsoever. Attempting to then install using the script results in the same error.

What is odd is that I first started playing around with Wazo earlier today, and have gone through a few different installs (I was mostly trying to install with IcrediblePBX), and I did et it to install once, but every other time since, I have run into this error.

Any insight at all is greatly appreciated.


Replies (2)

RE: Cannot install latest version - Added by Alan Murrell 8 days ago

THis is resolved. Installing from ISO and choosing to not configure a network when asked during the install allowed the system to install normally. I have been playing around with a few things all day, and will very likely have other questions, but I will post them separately :-)

RE: Cannot install latest version - Added by François Blackburn 7 days ago

Thanks, it's fixed now !

    (1-2/2)