Project

General

Profile

Cannot upgrade wazo after 17.15

Added by Andrew Wells 3 months ago

I have tried to upgrade, even doing wazo-upgrade-d, but i look at the logs and it doesnt seem to connect to any upgrde servers. I have also read that i need to go through the wizard but i installed this a long tme ago, so why do i need to do the wizard.

Could someone please give me a tip on this as i dont want to start from scratch.

Thanks

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Apr 5 16:39:30 2018
root@wazo:~# wazo-upgrade -d
W: Failed to fetch http://mirror.wazo.community/debian/dists/wazo-dev/main/binary-amd64/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
Upgrading wazo-upgrade
Reading package lists...
Building dependency tree...
Reading state information...
xivo-upgrade is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be upgraded:
linux-image-3.16.0-6-amd64 wget
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 35.0 MB of archives.
After this operation, 362 kB disk space will be freed.
Get:1 http://security.debian.org/ jessie/updates/main wget amd64 1.16-1+deb8u5 [496 kB]
Get:2 http://security.debian.org/ jessie/updates/main linux-image-3.16.0-6-amd64 amd64 3.16.56-1+deb8u1 [34.5 MB]
Fetched 35.0 MB in 3s (10.8 MB/s)
Download complete and in download only mode
root@wazo:~# wazo-upgrade
W: Failed to fetch http://mirror.wazo.community/debian/dists/wazo-dev/main/binary-amd64/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
Upgrading wazo-upgrade
Reading package lists...
Building dependency tree...
Reading state information...
xivo-upgrade is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Purging FAI packages...
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package .*$
E: Couldn't find any package by regex '
(xivo-fai|xivo-wheezy-fai).*$'
Ign http://mirror.csclub.uwaterloo.ca jessie InRelease
Hit http://mirror.csclub.uwaterloo.ca jessie-updates InRelease
Hit http://mirror.csclub.uwaterloo.ca jessie Release.gpg
Hit http://mirror.csclub.uwaterloo.ca jessie Release
Ign http://mirror.wazo.community wazo-dev InRelease
Hit http://security.debian.org jessie/updates InRelease
Get:1 http://mirror.csclub.uwaterloo.ca jessie-updates/main Sources [17.2 kB]
Ign http://mirror.wazo.community wazo-dev Release.gpg
Get:2 http://mirror.csclub.uwaterloo.ca jessie-updates/main amd64 Packages/DiffIndex [11.8 kB]
Get:3 http://mirror.csclub.uwaterloo.ca jessie-updates/main Translation-en/DiffIndex [3,688 B]
Ign http://mirror.wazo.community wazo-dev Release
Ign http://mirror.wazo.community wazo-dev/main amd64 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main amd64 Packages
Get:4 http://mirror.csclub.uwaterloo.ca jessie/main Sources [7,054 kB]
Hit http://security.debian.org jessie/updates/main Translation-en
Get:5 http://mirror.csclub.uwaterloo.ca jessie/main amd64 Packages [6,789 kB]
Get:6 http://mirror.csclub.uwaterloo.ca jessie/main Translation-en [4,583 kB]
Ign http://mirror.wazo.community wazo-dev/main Translation-en_CA
Ign http://mirror.wazo.community wazo-dev/main Translation-en
Err http://mirror.wazo.community wazo-dev/main amd64 Packages
404 Not Found
Fetched 32.7 kB in 2s (11.6 kB/s)
W: Failed to fetch http://mirror.wazo.community/debian/dists/wazo-dev/main/binary-amd64/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
installed version : 17.15
proposed update : 17.15
Would you like to upgrade your system (all services will be restarted) [Y/n]? n
root@wazo:~#


Replies (1)

RE: Cannot upgrade wazo after 17.15 - Added by François Blackburn 3 months ago

The distribution wazo-dev doesn't exist anymore. To upgrade you need to switch to the phoenix distribution with the following command:

xivo-dist phoenix

And after that you can upgrade by following the instructions on the documentation

    (1-1/1)