Project

General

Profile

Cannot install

Added by john gordon almost 2 years ago

Not a very good first impressing when I can't even get the software installed. Googling around lots of other people having similar problems going back several months.

I have installed this project before when it was called xivo and never had this many problems.

If I can't even get the software installed it doesn't give me a very warm fuzzy feeling about the project.

I have worked through some problems but can't get past the install wizard validation step. Keeps throwing errors of duplicate entries and seems every time I run validation it adds more entries that then throw more duplicate errors. Surely someone can try fix this no? Install is the most basic thing that should just work if you want to get more people involved.

I am using the manual install script. That has problems as well. Instructions don't explain how to set locale before the script is run and if you don't do that the install fails and requires you to do it all over again or blow away the DB. Then the script fails on the first try. Running a second time seems to get most of it working but then xivo-confd keeps failing. The project name was changed but a lot of the packages apparently have not which only adds to the confusion and poor first impression.

I had high hopes but the project seems to have gotten worse. Sorry but I can't sugarcoat something this bad.


Replies (9)

RE: Cannot install - Added by Sylvain Boily almost 2 years ago

Hello,

Maybe it would be nice if you give us logs and more informations about your issues. For example what version did you test, on what server or cloud etc...

Sylvain

RE: Cannot install - Added by john gordon almost 2 years ago

Thanks for responding. I am using whatever version your install script installs. I do not know what you mean server vs cloud. I am using your install instructions which make no mention of "cloud".
http://documentation.wazo.community/en/stable/installation/installsystem.html

It would be nice if your install instructions at least explained how to set default locale instead of just saying you need to have it set. It's one short command as far as I know "dpkg-reconfigure locales" but it caused me to waste at least an hour of time because it was not explained how to do it or even check for it. How hard would it be for your install script to check if that is set before proceeding further and totally breaking the install?

I would assume you guys at least test a basic install and know about these issues. Like I said I can't get past the validation step. I am assuming you are aware of the fact your validation step tries to write duplicate entries when it fails because there is apparently not enough intelligence built in to not do that.

I am aware that I could install from ISO which probably has a better chance of working. I might have to do that since it is not possible to install from script. I do not like ISO installs that do everything for you because I will not know how to fix anything when the inevitable problems occur.

RE: Cannot install - Added by Sylvain Boily almost 2 years ago

Well... so have a good day :)

RE: Cannot install - Added by john gordon almost 2 years ago

So do you guys plan to fix this or should I not bother wasting any more time on this project?

I would think you want more people using the software and reporting back issues. Can't do that if we can't even get it installed. It's not just me. I found lots of comments about not being able to get it working when doing a search. Sorry again for not sugarcoating anything. I am sure people have worked hard on this project in the past but based on my latest experience it looks like abandonware to me.

RE: Cannot install - Added by Sylvain Boily almost 2 years ago

If you want help, give us more informations.
If you only want to troll, don't waste your time.
If you think we can help you without any informations about your issue, yes you're crazy :)
If you think we don't have any test check https://jenkins.wazo.community.

RE: Cannot install - Added by john gordon almost 2 years ago

Do trolls spend half a day trying to install your software? I am trying to figure out if this is a serious project or someones weekend hobby or abandonware.

I count at least 18 separate log files that start with xivo and 3 that start with wazo. So the log files appear to be a mess as well.

I have no shortage of errors in the log files that I can copy/paste.

IP is anonymized.

IntegrityError: (raised as a result of Query-invoked autoflush; consider using a session.no_autoflush block if this flush is occurring prematurely) (IntegrityError) duplicate key value violates unique constraint "netiface_ifname_key"
DETAIL: Key (ifname)=(venet0:0) already exists.
'INSERT INTO netiface (ifname, hwtypeid, networktype, type, family, method, address, netmask, broadcast, gateway, mtu, vlanrawdevice, vlanid, options, description) VALUES (%(ifname)s, %(hwtypeid)s, %(networktype)s, %(type)s, %(family)s, %(method)s, %(address)s, %(netmask)s, %(broadcast)s, %(gateway)s, %(mtu)s, %(vlanrawdevice)s, %(vlanid)s, %(options)s, %(description)s) RETURNING netiface.id' {'broadcast': '', 'description': 'Wizard Configuration', 'family': 'inet', 'hwtypeid': 1, 'vlanid': None, 'gateway': u'0.0.0.0', 'vlanrawdevice': None, 'netmask': u'255.255.255.255', 'options': '', 'address': u'xx.xx.xx.xx', 'networktype': 'voip', 'ifname': u'venet0:0', 'mtu': 1500, 'type': 'iface', 'method': 'static'}

wazo-service status
Checking database...
OK
Checking services...
running dahdi
running wazo-admin-ui
running wazo-plugind
running wazo-webhookd
running xivo-sysconfd
failed xivo-confgend
failed xivo-confd
failed xivo-auth
running wazo-call-logd
running xivo-dxtora
running xivo-provd
running xivo-agid
running asterisk
running xivo-amid
running xivo-agentd
failed xivo-ctid
running xivo-dird
running xivo-dird-phoned
running xivo-ctid-ng
running xivo-websocketd

RE: Cannot install - Added by Sylvain Boily almost 2 years ago

Where did you installed wazo?
There is some issues with the wizard and your configuration. You need to reset it http://documentation.wazo.community/en/stable/administration/cli_tools/cli_tools.html#wazo-reset and give us the first problem.
How do you pass the wizard?
What version do you want to install?
vnet0:0 network interface and gateway 0.0.0.0 is not a classical network installation, so i suspect you are using a CLOUD environment who need a specific workaround to pass our wizard.

Wazo is not an asterisk config file generator. If you are looking for an asterisk generator, wazo is clearly not the software you need.

RE: Cannot install - Added by Sylvain Boily almost 2 years ago

And we already talked about this issue before we forked xivo to wazo. https://projects.wazo.community/boards/1/topics/5957?r=7958#message-7958

RE: Cannot install - Added by john gordon almost 2 years ago

Thanks for the response.

I don't think it is the same issue. The install script completes after second try and first try doesn't have those same errors. Gateway is now automatically set to 0.0.0.0 and debian 8 has been working just fine on OpenVZ for a long time now. The failure now is in GUI wizard setup at validation step. I got this to install just fine a year ago on exactly the same virtualization when this project was called Xivo.

I would think the first thing the developer(s?) would do after a name change is run find/replace on all the source code. I know it's not that straight forward but on properly written code it should not be much more work that than for 99% of the code, and maybe some symlinks. It makes me wonder how active this project is. Right now it's kind of a mess with some things called Xivo and some called Wazo. Looks like some errors may be a result of that.

If your GUI is configuring Asterisk then you are generating config files because that is how Asterisk works. Even if you are running Asterisk realtime you are still ultimately just configuring Asterisk. Not sure how you can say that you are not doing that.

    (1-9/9)