Wazo 17.07 crashed my system

Added by Andrew Wells 3 months ago

HI Guys,

I installed 17.07 and was having issues as only a few of the modules would intall. I got this https error on this high port (ie sometihng like 9275) and then i decided to reboot the vm (that it is hosted on) and it wont come back on. I can access it from the terminal and asterisk seems to be running, but i cannot access it from http or ssh or ping it.

I can reinstall if necessary but i thought i would let you know first.

Please advsie


Replies (15)

RE: Wazo 17.07 crashed my system - Added by Pascal Cadotte-Michaud 3 months ago

Hi,

no ssh, http and ping makes it feel like your IP has been blocked by fail2ban. Do you have a softphone trying to register with the wrong credentials?

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 3 months ago

I am sorry, i didnt see this reply button, and i didnt get a response via email

I really want to get this going again, but i am at my knowledge limit, I used the command service fail2ban stop, and nothing changed.

RE: Wazo 17.07 crashed my system - Added by Pascal Cadotte-Michaud 3 months ago

Hi,

I think fail2ban needs a restart to reset all of its firewall rules.

If its not fail2ban its probably your network that is not configured correctly.

During the wizard at the installation Wazo uses its current ip address and sets it in its "/etc/network/interfaces". If that IP address was a DHCP lease, it's possible that another device on your network got the same IP address after the original lease expired. You should make sure your server IP address is either outside of your DHCP address range or that the IP address that you received is reserved for mac address.

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 3 months ago

We are not using dhcp, we are using a static ip.

This all happened when i was installing the admin modules that come with 17..07

What should i do?

I cant ping it, i cant use http, i can only log in via terminal.

RE: Wazo 17.07 crashed my system - Added by François Blackburn 2 months ago

A restart of fail2ban doesn't remove bans
Can you check with the command iptables -nL if your ip is listed?

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 2 months ago

i see that fall2ban has no addresses, and the ip for this machine, 98.158.137.112 is listed as allowed...twice?

I see a few entries for udp of attempted logins, but not much else.

What is the next step, thanks for your help.

RE: Wazo 17.07 crashed my system - Added by J Az 2 months ago

Just fishing here but...

Who is the cloud provider? Do they have a firewall/whitelist ahead of your machine that may be blocking your local machine/WAN IP?
Same thoughts about your LAN/local machine - any proxy/traffic monitor/firewall that may be blocking your machine's outbound or the target VM address?

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 2 months ago

This is our own network, we are our own provider. Everything was good until i started installing the plugins, without paying to attention to the order and the web interface froze. I rebooted the machine and this is what i ended up with. There is nothing blocking anything on this ip. The issue solely lies on the wazo itself.

I can terminal into the machine but that is it.

I dont think it is a firewall issue, i think it is an application issue.

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 2 months ago

When i mentioned the wazo, i meant the machine. There are no external forces like firewalls or proxies that are getting in the way.

RE: Wazo 17.07 crashed my system - Added by J Az 2 months ago

Yeah I did say I was fishing. Though I'm not sure how wazo modules would block you being able to ping the machine. That seems much lower in the stack than wazo would control.
Maybe return to an earlier backup and retry the upgrade. I just upgraded from 17.03 to.07 without incident so might be worth a shot to just try again.

RE: Wazo 17.07 crashed my system - Added by Sylvain Boily 2 months ago

The module from incrediblepbx (travelin' man3) is a firewall who deny traffic. Have you install it?

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 2 months ago

HI Sylvain,

I may have, i dont remember at this point. Is there a command to get rid of it, if i did.

Thanks

RE: Wazo 17.07 crashed my system - Added by Sylvain Boily 2 months ago

Yes, it's possible to search in packaging system with apt-cache search incrediblepbx for exemple.
And remove the package.

On the dev version there is now a CLI wazo-plugind-cli.

Check with iptables -L -n

RE: Wazo 17.07 crashed my system - Added by Andrew Wells 2 months ago

HI Sylvain...now that is incredible. I have now removed it completely. This plugin has kept me from accessing it for over a month....i think this plugin belongs in the trash bin. I will avoid anything incredible in the future...i think they need to change it to credible....

Thanks

RE: Wazo 17.07 crashed my system - Added by J Az 2 months ago

So there was a firewall...

Caveat emptor - unless your PBX will not be internet reachable in any way I would think twice about trashing the primary protection factor from hacking and phreaking.
TM3 firewall is pretty effective ime when used properly.

J.

(1-15/15)